
GSoCSecurityAccepted in 2026
The Libreswan Project
Encrypting the Internet with IKE / IPsec VPN
- 13
- Projects
- 7
- Years accepted
- 3
- In 2026
Projects by year
132026
3 acceptedShow
Add HOST-TO-HOST Support on BSD
Accepted project · by Amrinder Singh
The host to host ipsec transport mode works on Linux but does not work on any of the BSDs. The problem is a lack of IKE socket bypass , transport...
Add Support For Announcing Authentication Methods To Libreswan
Accepted project · by Osema Fadhel
Currently, during an IKEv2 negotiation in Libreswan, each peer independently selects its authentication method without knowing what the other side...
Optimising the lookup time for ACQUIRE messages sent by kernel
Accepted project · by Vinayak Sandur
When an IPsec-encrypted packet matches a trap policy in the kernel, the kernel notifies IKE daemon (Pluto) via an ACQUIRE Netlink message. Then Pluto...
2021
1 acceptedShow
2020
3 acceptedShow
- IKEv2 Interop testing with OpenBSDRavi Teja CMS
- Add Support for RFC 5723 'Session Resumption' and RFC 6023 'Childless Initiation of SA'Nupur Agrawal
- INTERMEDIATE exchange for IKEv2Yulia Kuzovkova
2019
1 acceptedShow
- Opportunistic IPsec development using LetsEncryptRishabh Chaudhary
2018
3 acceptedShow
- Extend RFC-7427 Signature Authentication support to IKEv2 with ECC / EDDSA supportSahana Prasad
- Implementing “Group Key Management using IKEv2” IETF draft, RFC 5685 - “Redirect Mechanism for IKEv2” and/or RFC 5723 - “IKEv2 Session Resumption”Vukašin Karadžić
- Web based Certificate and Profile User InterfaceRishabh Chaudhary